REST API retrieves incomplete list of registered submissions

I’m trying to generate a list of all registered submissions using the REST API, but don’t seem to be retrieving a complete list.

I use:

https://0-api-crossref-org.library.scad.edu/prefixes/10.51415/works?select=DOI&rows=1000
and
https://0-api-crossref-org.library.scad.edu/prefixes/10.51415/works?&select=DOI&rows=1000&offset=1000

This gives me all 1991 results: “total-results”: 1991.

However, omitted from these results are several DOIs that are registered and do resolve, including: 10.51415/ajims.v4i1.954

And I get ‘resource not found’ for:

https://0-api-crossref-org.library.scad.edu/works/10.51415/ajims.v4i1.954

Yet, https://0-doi-org.library.scad.edu/10.51415/ajims.v4i1.954 resolves.

I don’t know where I’ve gone wrong.

Update:
https://0-api-crossref-org.library.scad.edu/works/10.51415/ajims.v4i1.954 now retrieves the record, but there are others, such as https://0-api-crossref-org.library.scad.edu/works/10.51415/ajims.v4i1.953, still with ‘Resource not found.’

Maybe I just need to wait a couple of days? Still, it seems weird to me that a DOI can resolve yet not be retrievable through the API.

Hi,

You haven’t done anything wrong! The problem is on our end.

The process which indexes registered DOIs in the REST API has been intermittently struggling lately. The missing DOIs are registered (i.e. they resolve at the handle, as you’ve seen) and they are indexed in our older, XML API. But, they’re not making it into the REST API or any of its derivative services.

Our technical team is aware of the problem and investigating.

If you send us an email at support@crossref.org with any DOIs that you get that “resource not found” for in the REST API, we’ll ask one of our developers to re-push them for indexing.

Apologies for the inconvenience.

-Shayn

2 Likes